#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\[?(?P<series>[^0-9]+)(?P<episode>\[?\d+\]?)\s*\]?(\s*[\-]\s*)(?P<title>.*)(\s*[\-]\s*)(?P<author>.*)"
Local $sString = "Bluewater Bay 10 - Rain Shadow - L A Witt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")