re = /\[?(?P<series>[^0-9]+)(?P<episode>\[?\d+\]?)\s*\]?(\s*[\-]\s*)(?P<title>.*)(\s*[\-]\s*)(?P<author>.*)/mi
str = 'Bluewater Bay 10 - Rain Shadow - L A Witt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end