package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^whatever=[^;]*; |; whatever=[^;]*)`)
var str = `Cookie: header1=123; whatever=cookievalue1234; header2=789;`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}