const regex = new RegExp('[^,]*[A-Za-z0-9]{5}[^,]*', 'gm')
const str = `Accounts Payable Goods for Resale
Corporate Finance, Financial Engineering,
TBD,
Goods for Not Resale, SAP,
Jack Ryan, Tom O,
Stack Over Flow, StackOverFlow,
Jurassic Park, IT
GOT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}