package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\([0-9]*\))?\s*([^\,]*(\,)?)*`)
var str = `(1) Costume, (41) Hat, 1 Magic Wand Accessory`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}