using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d.\d{0,3}(?= A)";
string input = @"</tr><tr><td>Current: </td><td>0.190 A</td></tr><tr><td>Power: ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}