re = /\d.\d{0,3}(?= A)/
str = '</tr><tr><td>Current: </td><td>0.190 A</td></tr><tr><td>Power: '
# Print the match result
str.match(re) do |match|
puts match.to_s
end