import re
regex = re.compile(r"(\b\w+\s)\1", flags=re.IGNORECASE | re.MULTILINE)
test_str = "el texto que se escribe en plan rutinario asi mientras se hacen otras cosas con el ojo izquierdo izquierdo sobre todo si se copia y y pega bueno eso es una fuente inagotable de errores y errores y errores tantos que hay quien se dedica a encontrar algunos de ellos ellos con magnificas y sofisticadas aplicaciones como esto del regex que suena a comprimidos con sabor a menta para aliviar la acidez de estomago despues de de comidas abusivas "
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)