package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"[^\"]+\"`)
var str = `"112233"|"Roshan"|"25"|" FAX 022 3987789 \| TEL 77766288892 \| abc "|"Male"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}