package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]+\.[a-zA-Z]\.[a-zA-Z]+\.[a-zA-Z]+@mail.mil|^[a-zA-Z]+\.[a-zA-Z]+@mail.mil$`)
var str = `joe.s.smith.ctr@mail.mil
joe.smith@mail.mil`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}