using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/[\s\S]*";
string input = @"The test has some url in the last. extract the text starting from https to the end of the string<br></br>https://xyz.com/index.html";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}