package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https:\/\/[\s\S]*`)
var str = `The test has some url in the last. extract the text starting from https to the end of the string<br></br>https://xyz.com/index.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}