$re = '/https:\/\/[\s\S]*/';
$str = 'The test has some url in the last. extract the text starting from https to the end of the string<br></br>https://xyz.com/index.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);