// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https:\/\/[\s\S]*").unwrap();
let string = "The test has some url in the last. extract the text starting from https to the end of the string<br></br>https://xyz.com/index.html";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}