re = /^ *#define +([a-zA-Z][\w]*)\( *([a-zA-Z_]\w*)(?: *, *([a-zA-Z_]\w*) *) *\) *(.+) *$/m
str = ' #define AD9D9( _Xy_ , Y9_y3 ) x + y + 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end