using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.([^.]+)$";
string input = @"804269_General Motors Financial Company Inc._02-05-2020_10-K_0000804269-20-000006.txt.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}