using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-\s([^\(]+)";
string input = @"S-1 - Wealthbridge Acquisition Ltd (0001753673) (Filer)
S-1/A - KinerjaPay Corp. (0001494162) (Filer)
S-1 - CYTY CAPITAL SOLUTIONS INC (0001762609) (Filer)
S-1/A - NORTHWEST OIL & GAS TRADING COMPANY, INC. (0001762533) (Filer)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}