#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/(?:www\.)?([-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b)*(\/[\/\d\w\.-]*)*(?:[\?\;])*(?:[-a-zA-Z0-9@:%_\+.~#?&\/\/=\;]*)*"
Local $sString = "https://regex101.com/" & @CRLF & _
"ftp://daqdsqdq" & @CRLF & _
"azd ade zef ezfhttps://toto.dsdaz?page=1#sldlsdlsd&sqdqsd#sqdqsdsdza"ad azd azd" & @CRLF & _
"azd ade zef ezfhttps://toto.dsdaz?page=1#sldlsdlsd&sqdq;sd#sqdqsdsdza"ad azd azd" & @CRLF & _
"# OpenWrt Build System (PGP key for unattended snapshot builds)" & @CRLF & _
"curl 'https://git.openwrt.org/?p=keyring.git;a=blob_plain;f=gpg/626471F1.asc' | gpg --import \" & @CRLF & _
"curl 'https://git.openwrt.org/?p=keyring.git;a=blob_plain;f=gpg/626471F1.asc' | gpg --import \" & @CRLF & _
"" & @CRLF & _
"from https://raw.githubusercontent.com/openwrt/docker/6d75cb142cba919faa74743c27c97b64c679a56a/docker-common.sh" & @CRLF & _
"# OpenWrt Build System (PGP key for unattended snapshot builds)" & @CRLF & _
"curl 'https://git.openwrt.org/?p=keyring.git;a=blob_plain;f=gpg/626471F1.asc' | gpg --import \" & @CRLF & _
" && gpg --fingerprint --with-colons '<pgpsign-snapshots@openwrt.org>' | grep '^fpr:::::::::54CC74307A2C6DC9CE618269CD84BCED626471F1:$' \" & @CRLF & _
" && echo '54CC74307A2C6DC9CE618269CD84BCED626471F1:6:' | gpg --import-ownertrust" & @CRLF & _
"" & @CRLF & _
"https://www.asd.google.com/search?q=some+text¶m=3#dfsdf" & @CRLF & _
"https://www.google.com" & @CRLF & _
"http://google.com/?q=some+text¶m=3#dfsdf" & @CRLF & _
"https://www.google.com/api/?" & @CRLF & _
"https://www.google.com/api/login.php" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")