$re = '/^.*\b(particular phrase)\W+((?:\w+\W+){3}\w+).*$/m';
$str = 'Blah blah particular phrase Extract These Words Please for the blah blah. Ignore blah this other stuff blah blah, blah.';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;