re = /(?:$|^|)(red-|blue-|indigo-|cool-gray-|pink-|yellow-|teal-|gray-|orange-|green-|purple-)(50|100|200|300|400|500|600|700|800|900)(?:$|^|)/i
str = 'pink-300 red-400 blue-300 teal-800 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end