import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\w.{1,25})\\s";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vestibulum semper nisi id laoreet blandit. Nulla sit amet nisl non purus egestas ornare. Nullam pretium est sed ultrices imperdiet.\n\n"
+ "Phasellus dignissim tempus pretium. Praesent odio arcu, mollis non tincidunt eget, varius id ipsum. Nullam erat felis, varius non bibendum non, ullamcorper sit amet urna. ";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}