$re = '/[a-zA-Z_]+ /m';
$str = 'foo$12___bar___$34wilma buzz
hello$ there 12 h___uhuhu$12 otherstuff
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);