const regex = /(?m)^(?!Accounts).*(?:\n.*)?/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^(?!Accounts).*(?:\\n.*)?', 'm')
const str = `Accounts Payable
Company Name
Some Road
Some Town `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}