const regex = /(\S)[^\S\n]*(\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S)[^\\S\\n]*(\\n)', 'gm')
const str = `
There are spaces at the end of line
No space at the end of line
`;
const subst = `$1<br><br>$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);