import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(?\\d{3}\\)?[\\s.-]?\\d{3}[\\s.-]?\\d{4}$";
final String string = "1-718-444-1122\n"
+ "718-444-1122\n"
+ "(718)-444-1122\n"
+ "17184441122\n"
+ "7184441122\n"
+ "718.444.1122\n"
+ "1718.444.1122\n"
+ "1-123-456-7890\n"
+ "1 123-456-7890\n"
+ "1 (123) 456-7890\n"
+ "1 123 456 7890\n"
+ "1.123.456.7890\n"
+ "+91 (123) 456-7890\n"
+ "18005551234\n"
+ "1 800 555 1234\n"
+ "+1 800 555-1234\n"
+ "+86 800 555 1234\n"
+ "1-800-555-1234\n"
+ "1 (800) 555-1234\n"
+ "(800)555-1234\n"
+ "(800) 555-1234\n"
+ "(800)5551234\n"
+ "800-555-1234\n"
+ "800.555.1234\n"
+ "18001234567\n"
+ "1 800 123 4567\n"
+ "1-800-123-4567\n"
+ "+18001234567\n"
+ "+1 800 123 4567\n"
+ "+1 (800) 123 4567\n"
+ "1(800)1234567\n"
+ "+1800 1234567\n"
+ "1.8001234567\n"
+ "1.800.123.4567\n"
+ "+1 (800) 123-4567\n"
+ "18001234567\n"
+ "1 800 123 4567\n"
+ "+1 800 123-4567\n"
+ "+86 800 123 4567\n"
+ "1-800-123-4567\n"
+ "1 (800) 123-4567\n"
+ "(800)123-4567\n"
+ "(800) 123-4567\n"
+ "(800)1234567\n"
+ "800-123-4567\n"
+ "800.123.4567\n"
+ "1231231231\n"
+ "123-1231231\n"
+ "123123-1231\n"
+ "123-123 1231\n"
+ "123 123-1231\n"
+ "123-123-1231\n"
+ "(123)123-1231\n"
+ "(123)123 1231\n"
+ "(123) 123-1231\n"
+ "(123) 123 1231\n"
+ "+99 1234567890\n"
+ "+991234567890\n"
+ "(555) 444-6789\n"
+ "555-444-6789\n"
+ "555.444.6789\n"
+ "555 444 6789\n"
+ "18005551234\n"
+ "1 800 555 1234\n"
+ "+1 800 555-1234\n"
+ "+86 800 555 1234\n"
+ "1-800-555-1234\n"
+ "1.800.555.1234\n"
+ "+1.800.555.1234\n"
+ "1 (800) 555-1234\n"
+ "(800)555-1234\n"
+ "(800) 555-1234\n"
+ "(800)5551234\n"
+ "800-555-1234\n"
+ "800.555.1234\n"
+ "(003) 555-1212\n"
+ "(103) 555-1212\n"
+ "(911) 555-1212\n"
+ "18005551234\n"
+ "1 800 555 1234\n"
+ "+86 800-555-1234\n"
+ "1 (800) 555-1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}