using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\b(?!.*\.{2})[a-zA-Z.]+(?: [a-zA-Z.]+)\b$";
string input = @"Matched:
S. Something
S .Something
Not matched:
...
S.. Something";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}