$re = '/^\b(?!.*\.{2})[a-zA-Z.]+(?: [a-zA-Z.]+)\b$/m';
$str = 'Matched:
S. Something
S .Something
Not matched:
...
S.. Something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);