#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<div class="row">[\n\s]*<div class="col-md-6">[^<]*<\/div>[ \n\s]*<\/div>"
Local $sString = "<div class="container header">" & @CRLF & _
" <div class="row">" & @CRLF & _
" <div class="col-md-6">This is the target text</div>" & @CRLF & _
" </div>" & @CRLF & _
"</div><span /><a href...></a>Whatever" & @CRLF & _
"<div class="container header">" & @CRLF & _
" <div class="row">" & @CRLF & _
" <div class="col-md-6">This is the target text</div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")