$re = '/<div class="row">[\n\s]*<div class="col-md-6">[^<]*<\/div>[ \n\s]*<\/div>/s';
$str = '<div class="container header">
<div class="row">
<div class="col-md-6">This is the target text</div>
</div>
</div><span /><a href...></a>Whatever
<div class="container header">
<div class="row">
<div class="col-md-6">This is the target text</div>
</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);