package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([-\+]?\d+,[-\+]?\d+)`)
var str = `@@ -74,6 +73,7 @@
<dependency> <groupId>com.jolbox</groupId>
<artifactId>bonecp-test
- commons</artifactId>
+ <classifier>${project.classifier}</classifier>
<scope>test</scope>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}