import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^GO\\b";
final String string = "SET ANSI_NULLS ON\n"
+ "GO \n"
+ "SET QUOTED_IDENTIFIER ON\n"
+ "GO \n"
+ "--Não deve pegar o GO aqui ou no final do texto mesmo que essa linha termine com GO \n"
+ "--Mas deve encontrar nas linhas 2 e 4 acima e na abaixo.\n"
+ "GO \n"
+ "GOIAS";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}