use strict;
my $str = 'SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
--Não deve pegar o GO aqui ou no final do texto mesmo que essa linha termine com GO
--Mas deve encontrar nas linhas 2 e 4 acima e na abaixo.
GO
GOIAS';
my $regex = qr/^GO\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}