import Foundation
let pattern = #"^GO\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
--Não deve pegar o GO aqui ou no final do texto mesmo que essa linha termine com GO
--Mas deve encontrar nas linhas 2 e 4 acima e na abaixo.
GO
GOIAS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)