#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0$)((1\d|2[0-4]|\d)?\d{1,3}|25000)$"
Local $sString = "123" & @CRLF & _
"0" & @CRLF & _
"1" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"50000" & @CRLF & _
"25001" & @CRLF & _
"25000" & @CRLF & _
"24999" & @CRLF & _
"24001" & @CRLF & _
"19999" & @CRLF & _
"555" & @CRLF & _
"23" & @CRLF & _
"20000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")