use strict;
my $str = '123
0
1
9
10
50000
25001
25000
24999
24001
19999
555
23
20000';
my $regex = qr/^(?!0$)((1\d|2[0-4]|\d)?\d{1,3}|25000)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}