// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[-\d](?:-|\B\d){4}[A-Z\d-]*$").unwrap();
let string = "12345ABC
12345123
1234-1
1234--1
1----1AB
-----
--1--BB
----1-
1-1--11
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}