// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^([A-Y])?\s*(\d{0,4})\s?([a-d])?)|(?:^((?:\w+)|(?:\w+,)|(?:\w+, \w*))?\s*((?:&{1,2}|and|or|\|{2})\s+(?:.*)*)*)
").unwrap();
let string = "thra
^\\s*((?:\\w+)(?:,?\\s?)(?:,\\s\\w+\\s*)*)
^\\s*?((?:\\w+){1}\\s*(?:(?:,?)|(?:,\\s\\w+))*\\s*)
\\s*((?:&{1,2}|and|or|\\|{2})\\s+(?:.*)*)*
(?:^([A-Y] +)*(\\d{0,4}) ?(a-d))|";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}