#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\d]*)(.|,)[\d](e|E)[\d]+"
Local $sString = "Valid floating points:" & @CRLF & _
"1" & @CRLF & _
"+1" & @CRLF & _
"-1" & @CRLF & _
"65" & @CRLF & _
"+65" & @CRLF & _
"-65" & @CRLF & _
"5.2" & @CRLF & _
"5,2" & @CRLF & _
"5.225" & @CRLF & _
"5,225" & @CRLF & _
"985.225" & @CRLF & _
"985,225" & @CRLF & _
"985." & @CRLF & _
",225" & @CRLF & _
"+5.2" & @CRLF & _
"+5,2" & @CRLF & _
"+5.225" & @CRLF & _
"+5,225" & @CRLF & _
"+985.225" & @CRLF & _
"+985,225" & @CRLF & _
"+985." & @CRLF & _
"+,225" & @CRLF & _
"-5.2" & @CRLF & _
"-5,2" & @CRLF & _
"-5.225" & @CRLF & _
"-5,225" & @CRLF & _
"-985.225" & @CRLF & _
"-985,225" & @CRLF & _
"-985." & @CRLF & _
"-,225" & @CRLF & _
"5.2E3" & @CRLF & _
"5.2e3" & @CRLF & _
"+5.2e3" & @CRLF & _
"-5.2e3" & @CRLF & _
"5,2E3" & @CRLF & _
"5,2e3" & @CRLF & _
"-5,2e3" & @CRLF & _
"+5,2e3" & @CRLF & _
"5.2e112" & @CRLF & _
"+5.2e112245" & @CRLF & _
"-5.2e99999" & @CRLF & _
"5,2e112" & @CRLF & _
"-5,2e112245" & @CRLF & _
"+5,2e99999" & @CRLF & _
"5.2e+3" & @CRLF & _
"+5.2e+3" & @CRLF & _
"-5.2e+3" & @CRLF & _
"5,2e-3" & @CRLF & _
"-5,2e-3" & @CRLF & _
"+5,2e-3" & @CRLF & _
"5.e3" & @CRLF & _
"5.e+3" & @CRLF & _
"+5.e+3" & @CRLF & _
"-5.e+3" & @CRLF & _
"5,e-3" & @CRLF & _
"-5,e-3" & @CRLF & _
"+5,e-3" & @CRLF & _
",225e123" & @CRLF & _
"+,225e123" & @CRLF & _
"-,225e123" & @CRLF & _
".225e123" & @CRLF & _
"+.225e123" & @CRLF & _
"-.225e123" & @CRLF & _
"" & @CRLF & _
"Not floating points" & @CRLF & _
"," & @CRLF & _
"," & @CRLF & _
"," & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
".e" & @CRLF & _
",e" & @CRLF & _
".e2" & @CRLF & _
",e2" & @CRLF & _
",225e" & @CRLF & _
"+,225e" & @CRLF & _
"-,225e" & @CRLF & _
".225e" & @CRLF & _
"+.225e" & @CRLF & _
"-.225e"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")