$re = '/\R+(?=\d{2}:\d{2}:\d{2})/';
$str = 'bla bla.
14:39:51 info: pyku bla .
14:39:51 info:
14:39:51 info:
14:39:57 Sam: <span>pyk pyk</span>
14:43:15 on and on
14:43:59 you get an idea';
$subst = "<>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;