import Foundation
let pattern = #"\R+(?=\d{2}:\d{2}:\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
bla bla.
14:39:51 info: pyku bla .
14:39:51 info:
14:39:51 info:
14:39:57 Sam: <span>pyk pyk</span>
14:43:15 on and on
14:43:59 you get an idea
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)