#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?uim)^(\d+\.?\d*[fF]|\d+\.?(?![\p{L}_])\d*[fF]?|\d*\.\d+[fF]?)"
Local $sString = "10" & @CRLF & _
"50.0" & @CRLF & _
"" & @CRLF & _
"42.ToString()" & @CRLF & _
"0.1.GetType()" & @CRLF & _
"9..GetHashCode()" & @CRLF & _
"" & @CRLF & _
"45.1 // float" & @CRLF & _
"10f // float" & @CRLF & _
"0. // float" & @CRLF & _
"1 // int"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")