use strict;
my $str = 'Sample text:
test text long long test text
test text long long long long long long test text
test text long long test test long long long test text
How it should be:
test text long-long test text
test text long-long-long-long-long-long test text
test text long-long test test long-long-long test text
How does it work now:
test text long-long test text
test text long-long long-long long-long test text
test text long-long test test long-long long test text';
my $regex = qr/(\blong\b|\banyword\b)(-| )(\blong\b|\banyword\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}