$re = '/S\/?u?\/?n?\/?r?\/?i?\/?s?\/?e?/m';
$str = 'S/Su/Sun/Sunr/Sunri/Sunris/Sunrise';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);