#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^41:01:00\d{5}:\d{1,4}$"
Local $sString = "Совпадает" & @CRLF & _
"41:01:0010126:2614" & @CRLF & _
"41:01:0010114:51" & @CRLF & _
"41:01:0010113:291" & @CRLF & _
"41:01:0010112:19" & @CRLF & _
"Не совпадает" & @CRLF & _
"41:01:00101 26:2614" & @CRLF & _
"41:01:001114:51" & @CRLF & _
"41:01:1010113:291" & @CRLF & _
"41:01:001011219"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")