# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<command>\w{1,})(\s?-\s?(?P<description>.*))?"
test_str = ("avvisi\n"
"calcola - Evaluate one or more algebric expressions\n"
"caratteri - Count the characters in a text message (use it in reply)\n"
"ciclopi - CiloPi stations status\n"
"coop - Get UniCoop Firenze opening hours for Pisa Cisanello shop\n"
"doodle - Manage doodle-type surveys\n"
"help - Help\n"
"language - Change language settings\n"
"monitor - Monitor a web page and notify changes\n"
"note - Save up to 10 notes, callable via inline query\n"
"ping - Check if bot is online\n"
"quando - Get the original sending datetime for a message (use it in reply)\n"
"reminder - Set a reminder\n"
"suggestion - Send a suggestion to help improve the bot\n"
"tastiera - Send a keyboard with bot commands\n"
"ciaone\n"
"ciaone - fdfdf\n"
"della - f")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.