const regex = /(?<=\.\s+)(#[a-zA-Z]+ *)+(?! *[^\s])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\.\\s+)(#[a-zA-Z]+ *)+(?! *[^\\s])', 'gm')
const str = `#abc #def This is a test paragraph. #ads I only want to remove the hashtags after the full stop at the end and keep the hashtag at the center. These hashtags should be removed. #ads #ime #abc
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}