import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{1,2})? ?([A-Za-z]{3})? ?(\\d{4})?$";
final String string = "11\n"
+ "11 Jun\n"
+ "11 Jun 2025\n"
+ "2025\n"
+ "6\n"
+ "Jun";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}