re = /^(\d{1,2})? ?([A-Za-z]{3})? ?(\d{4})?$/m
str = '11
11 Jun
11 Jun 2025
2025
6
Jun'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end