package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*((([+]?((0?(\.[0-9]*)?|\.[0-9]+)|1(\.0*)?)([Ee][+-]?[0-9]+)?)\s+){2}([+]?((0?(\.[0-9]*)?|\.[0-9]+)|1(\.0*)?)([Ee][+-]?[0-9]+)?)\s*,?\s*)*$`)
var str = `0 1 .2 .3, .4 .5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}