// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9,]+)\)").unwrap();
let string = "MINI (0)
XS (0,5)
S (1-2)
L (1 person 1 sprint, 10)
XL (2 persons 1 sprint, 20)
TOO LARGE (100)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}